[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
Страница 1 из 11
Форум Panda3D - по русски » Panda3D » Для начинающих » даже запустить не получается (проблемы в маверике)
даже запустить не получается
foxДата: Пятница, 26.11.2010, 16:34 | Сообщение # 1
Рядовой
Группа: Пользователи
Сообщений: 2
Награды: 0
Репутация: 0
Статус: Offline
В вашем мануале написано вот это:

Quote
ImportError: No module named direct.directbase.DirectStart
Питон не может найти нужный пакет. Скорее всего у вас несколько версий питона и запущена не та, на которую рассчитана Панда. Так же стоит проверить наличие panda3d.pth в директории site-packages питона.

Но осталось непонятным как решить проблему
1.Как заставить запускаться нужную версию питона?
2.На какую версию питона рассчитана версия панды для маверика(ubuntu 10.10)?
3.Привязка панды к питону производится только файлом panda3d.pth или ещё как-то?
4.Насколько совместимы старые демки с этого и офф сайта с новыми версиями панды?
5.совмести-ли blender egg chicken с блендер 2.55?

Сообщение отредактировал fox - Пятница, 26.11.2010, 16:39
 
ninthДата: Пятница, 26.11.2010, 17:04 | Сообщение # 2
Admin
Группа: Администраторы
Сообщений: 1554
Награды: 5
Репутация: 46
Статус: Offline
Как ставил? Из репозитория или пакетом? Какие версии питона стоят?
У меня на 10.04 вроде никаких проблем не возникало.

chicken пока поддерживается до версии блендера <2.5 т.к. в новой версии сильно изменена API + по отзывам тех, кто пытался скриптить в новой версии - пачка глюков, потому ждём-с

Quote (fox)
Привязка панды к питону производится только файлом panda3d.pth или ещё как-то?

формально - да, но фактически может либо не запуститься вообще, либо падать, если скомпилена под другую версию питона.

Некоторые демки могут не запуститься, но в панде стараются сохранить совместимость, поэтому если вдруг что, то должно исправляться одной-двумя строчками.

 
foxДата: Пятница, 26.11.2010, 17:09 | Сообщение # 3
Рядовой
Группа: Пользователи
Сообщений: 2
Награды: 0
Репутация: 0
Статус: Offline
из Snapshot Builds скачал deb пакет для маверика.(Development SDK Builds) и дополнения при установке(т.е потянул все остальное панда рунтайм и пр)
в системе стоят 2.6 2.7 и 3.0

так стандартным питоном для маверика является 2.6 и по умолчанию запускается он и файл panda3d.pth в директории site-packages там есть

Сообщение отредактировал fox - Пятница, 26.11.2010, 18:09
 
ninthДата: Пятница, 26.11.2010, 19:28 | Сообщение # 4
Admin
Группа: Администраторы
Сообщений: 1554
Награды: 5
Репутация: 46
Статус: Offline
Рантайм не обязателен.
Ставить из экспериментальных снапшотов не самое лучшее начало для знакомства с софтиной)) Попробуй снести и поставь более-менее стабильный из репозитория.
Для начала ещё можешь попробовать принудительно запустить 2.6 - мало ли и разряженное ружжо стреляет - может и тут где-то косячок.
В общем стартуй python2.6 и попробуй импортировать from pandac.PandaModules import * что на это скажет?
 
Форум Panda3D - по русски » Panda3D » Для начинающих » даже запустить не получается (проблемы в маверике)
Страница 1 из 11
Поиск: