[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
Страница 12 из 30«1210111213142930»
Форум Panda3D - по русски » Panda3D » Общие вопросы » Вопросы
Вопросы
3dmaxДата: Понедельник, 23.03.2009, 20:45 | Сообщение # 166
Генерал-майор
Группа: Проверенные
Сообщений: 334
Награды: 0
Репутация: 1
Статус: Offline
забор не зеркалил, это в просмотрщике(ставлю кнопку prewie). Такая штука раньше была в самом блендере, но там все решилось нажинием копочки. Я именно этот "нормальный" забор экспортил. Но вот такая бадяга. Я думаю это именно z-тест глючит
 
3dmaxДата: Понедельник, 23.03.2009, 20:53 | Сообщение # 167
Генерал-майор
Группа: Проверенные
Сообщений: 334
Награды: 0
Репутация: 1
Статус: Offline
Про чикен, понял что надо теги добавлять, но блин гребыный инглиш.
Ща буду переводчиком пытаться.
 
3dmaxДата: Понедельник, 23.03.2009, 21:31 | Сообщение # 168
Генерал-майор
Группа: Проверенные
Сообщений: 334
Награды: 0
Репутация: 1
Статус: Offline
Может кто нить уже указывал теги в чикене ? Подскажите пожалуйста!!
 
ninthДата: Понедельник, 23.03.2009, 21:53 | Сообщение # 169
Admin
Группа: Администраторы
Сообщений: 1555
Награды: 5
Репутация: 46
Статус: Offline
Тэги указываются в панели Logic блендера, кнопка Add property
 
3dmaxДата: Понедельник, 23.03.2009, 23:51 | Сообщение # 170
Генерал-майор
Группа: Проверенные
Сообщений: 334
Награды: 0
Репутация: 1
Статус: Offline
ага получилось, но вот одна мелочь, в начале пишеться : <Tag> и вылетает с ошибкой
как сделать чтобы не писалось? Я добавлял в Confauto.prc надпись <Tag> , но ниче не дало, все равно та же ошибка.

И че делать с альфой,я так понимаю z-тест глючит ?

 
ninthДата: Вторник, 24.03.2009, 00:05 | Сообщение # 171
Admin
Группа: Администраторы
Сообщений: 1555
Награды: 5
Репутация: 46
Статус: Offline
У меня всё нормально. Скрин.

Прилепи сюда файл с глюком при z-тесте

Прикрепления: 6901729.png(2Kb)
 
3dmaxДата: Вторник, 24.03.2009, 00:38 | Сообщение # 172
Генерал-майор
Группа: Проверенные
Сообщений: 334
Награды: 0
Репутация: 1
Статус: Offline
вот ключной кусок забора исходник и то что сэкспортил
Прикрепления: models.zip(60Kb)
 
3dmaxДата: Вторник, 24.03.2009, 00:43 | Сообщение # 173
Генерал-майор
Группа: Проверенные
Сообщений: 334
Награды: 0
Репутация: 1
Статус: Offline
насчет тэгов.
В egg файле все равно пишеться <Tag> Obj { border }
опытным путем проверил именно из-за <Tag> файл вообще отказуеться загружаться.
как сделать чтобы <Tag> не появлялось ?
У тебя оно не появляется ?
 
ninthДата: Вторник, 24.03.2009, 02:04 | Сообщение # 174
Admin
Группа: Администраторы
Сообщений: 1555
Награды: 5
Репутация: 46
Статус: Offline
Нужно писать именно ObjectType
и текстуру к забору положи, плз
 
3dmaxДата: Вторник, 24.03.2009, 04:00 | Сообщение # 175
Генерал-майор
Группа: Проверенные
Сообщений: 334
Награды: 0
Репутация: 1
Статус: Offline
аа точно текстуру забыл.
Прикрепления: 5145746.png(150Kb)
 
3dmaxДата: Вторник, 24.03.2009, 04:38 | Сообщение # 176
Генерал-майор
Группа: Проверенные
Сообщений: 334
Награды: 0
Репутация: 1
Статус: Offline
в egg файл добавился параметр <ObjectType> { barrier }
но вот возникла интересная штука, текстура не грузиться земля тупо серого цвета как и все остальное,если бы не камера которая сквозь землю не проходит я бы подумал что земля просто не грузиться.

если <ObjectType> { barrier } убираю что все нормально.
в Confauto.prc файле написано egg-object-type-barrier <Collide> { Polyset descend }

на всяк случай приклудую этот файл.

 
3dmaxДата: Вторник, 24.03.2009, 04:39 | Сообщение # 177
Генерал-майор
Группа: Проверенные
Сообщений: 334
Награды: 0
Репутация: 1
Статус: Offline
.
Прикрепления: Poligon_Exp_2.zip(82Kb)
 
ninthДата: Вторник, 24.03.2009, 04:44 | Сообщение # 178
Admin
Группа: Администраторы
Сообщений: 1555
Награды: 5
Репутация: 46
Статус: Offline
Похоже что-то с настройками материала - я попробовал полностью удалить материал и просто назначить текстуру в UV без создания материала - глюк пропал, хотя текстура прозрачная - одна проблема - мипмаппинг тоже сбросился (может дело в нем?). Я просто не очень хорошо разбираюсь в материалахв блендере, но попробуй с их настройками поиграть.
Прикрепления: 7498131.jpg(42Kb)
 
ninthДата: Вторник, 24.03.2009, 04:50 | Сообщение # 179
Admin
Группа: Администраторы
Сообщений: 1555
Награды: 5
Репутация: 46
Статус: Offline
По поводу коллизий - нужен {Polyset keep descend} измени или создай свой тип в конфауто.
Для barrier назначен тип, который не выводит меш, а просто считает его барьером, т.к. обычно делают для коллизий низкополигональную невидимую модель, а для вывода на экран - детализованную.
 
3dmaxДата: Вторник, 24.03.2009, 05:29 | Сообщение # 180
Генерал-майор
Группа: Проверенные
Сообщений: 334
Награды: 0
Репутация: 1
Статус: Offline
изменил теперь в egg файле пишется <ObjectType> { Polyset keep descend }
но не запускаеться с этой строчкой. В конфиге ниче не менял.
 
Форум Panda3D - по русски » Panda3D » Общие вопросы » Вопросы
Страница 12 из 30«1210111213142930»
Поиск: