[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
Страница 1 из 3123»
Форум Panda3D - по русски » Panda3D » Общие вопросы » пару вопросов от новичка
пару вопросов от новичка
deemaaДата: Пятница, 21.10.2011, 17:03 | Сообщение # 1
Сержант
Группа: Пользователи
Сообщений: 27
Награды: 0
Репутация: 0
Статус: Offline
Всем, привет! подскажите, а работает ли панда с 3-им питоном? чето не нашел никакой информации
 
ninthДата: Пятница, 21.10.2011, 17:43 | Сообщение # 2
Admin
Группа: Администраторы
Сообщений: 1554
Награды: 5
Репутация: 46
Статус: Offline
Нет. На данный момент python 3 не поддерживается. По словам разработчиков переход на тройку не является приоритетной задачей и произойдёт не раньше чем третий питон станет более используемым чем второй, грубо говоря - стандартом.
 
deemaaДата: Пятница, 21.10.2011, 17:58 | Сообщение # 3
Сержант
Группа: Пользователи
Сообщений: 27
Награды: 0
Репутация: 0
Статус: Offline
спасибо, очень жаль что не работает. sad
Можно еще вопрос? когда я инсталлирую sdk c оф. сайта в папке с пандой появляется исполняемый файл интерпретатора. То есть в панду включен питон?
 
serg-kkzДата: Пятница, 21.10.2011, 18:22 | Сообщение # 4
Генерал-лейтенант
Группа: Модераторы
Сообщений: 679
Награды: 3
Репутация: 16
Статус: Offline
Quote (deemaa)
Можно еще вопрос? когда я инсталлирую sdk c оф. сайта в папке с пандой появляется исполняемый файл интерпретатора. То есть в панду включен питон?

Да. Это двиг где все включено smile


ООП  -  
 
serg-kkzДата: Пятница, 21.10.2011, 23:38 | Сообщение # 5
Генерал-лейтенант
Группа: Модераторы
Сообщений: 679
Награды: 3
Репутация: 16
Статус: Offline
Quote (deemaa)
спасибо, очень жаль что не работает.

Ну, расстраиваться сильно не надо, это дело времени.


ООП  -  
 
deemaaДата: Воскресенье, 23.10.2011, 15:30 | Сообщение # 6
Сержант
Группа: Пользователи
Сообщений: 27
Награды: 0
Репутация: 0
Статус: Offline
еще такой вопросик: у меня работают не все демо - примеры: некоторые падают с ошибкой (отправить отчет и т.п.), а в некоторых после запуска выскакивает надпись (что-то про видео карту). Запускаю на простеньком ноуте со встроенной видюхой. Вопросы:
1)что там такого навороченного что не работает ничего?
2)можно ли как-то заставить работать?
3)те которые падают с ошибкой, это тоже из-за видеокарты?
спасибо
 
serg-kkzДата: Воскресенье, 23.10.2011, 15:55 | Сообщение # 7
Генерал-лейтенант
Группа: Модераторы
Сообщений: 679
Награды: 3
Репутация: 16
Статус: Offline
Блин экстракционными способностями не обладаю.

1) Какие примеры не работаю?
2) Какой текст ошибки?
3) Возможно, из-за магнитных бурь!?

Открой в папке etc файл Config.prc и замени строку: basic-shaders-only #t на: basic-shaders-only #f может, поможет.

Пожалуста.


ООП  -  
 
ninthДата: Воскресенье, 23.10.2011, 16:10 | Сообщение # 8
Admin
Группа: Администраторы
Сообщений: 1554
Награды: 5
Репутация: 46
Статус: Offline
Самая вероятная причина - видеокарточка, особенно если интеловская. Интелы не сильно дружат с OpenGL. Падает скорее всего на примерах с использованием шейдеров. Попробуй на видео дрова обнови.
 
deemaaДата: Воскресенье, 23.10.2011, 20:55 | Сообщение # 9
Сержант
Группа: Пользователи
Сообщений: 27
Награды: 0
Репутация: 0
Статус: Offline
спасибо за ответы
вот примеры ошибок
пример fireflies - Toon shader: video driver does not support multiple render targets
cartoon shader - toon shader: videocard not powerful enough to do image postprocessing
distorshion - стандартная виндовая ошибка
glow filter - стандартная ошибка
shadows no shader - no arb_shadow
shadows advanced - ст. ошибка
teapot on TV - ст. ошибка

попробывал на др. ноуте покруче с 2 видюхами : intel GMA 3150 и NVIDIA ION . Все те же примеры не работают

Добавлено (23.10.2011, 20:55)
---------------------------------------------

Quote (serg-kkz)
Открой в папке etc файл Config.prc и замени строку: basic-shaders-only #t на: basic-shaders-only #f может, поможет.

не помогло
я в этих делах не силен, почему примеры не работают? ноут довольно мощный, мафию 2 тянет
спасибо


Сообщение отредактировал deemaa - Воскресенье, 23.10.2011, 20:50
 
serg-kkzДата: Воскресенье, 23.10.2011, 21:02 | Сообщение # 10
Генерал-лейтенант
Группа: Модераторы
Сообщений: 679
Награды: 3
Репутация: 16
Статус: Offline
Хм, в папке etc файле Config.prc

load-display pandagl
#load-display pandadx9
#load-display pandadx8
#load-display pandagles
#load-display tinydisplay

Закомментируй load-display pandagl

так #load-display pandagl

и строчку #load-display pandadx9 раскомментируй.

так load-display pandadx9

Должно получиться:

#load-display pandagl
load-display pandadx9
#load-display pandadx8
#load-display pandagles
#load-display tinydisplay

Интересно будет падать. Этим ты переключишь графическое API с OpenGL на DX. При этом шейдеры некоторые не должны работать. Ну и драйвера на видеокарту обнови если старые.


ООП  -  

Сообщение отредактировал serg-kkz - Воскресенье, 23.10.2011, 21:04
 
serg-kkzДата: Воскресенье, 23.10.2011, 21:09 | Сообщение # 11
Генерал-лейтенант
Группа: Модераторы
Сообщений: 679
Награды: 3
Репутация: 16
Статус: Offline
А вообще у тебя в ошибках написанно что видеодрайвер не поддерживет рендер шейдеров. Так я понял.

ООП  -  
 
deemaaДата: Воскресенье, 23.10.2011, 21:40 | Сообщение # 12
Сержант
Группа: Пользователи
Сообщений: 27
Награды: 0
Репутация: 0
Статус: Offline
Quote (serg-kkz)
load-display pandagl #load-display pandadx9 #load-display pandadx8 #load-display pandagles #load-display tinydisplay Закомментируй load-display pandagl так #load-display pandagl и строчку #load-display pandadx9 раскомментируй. так load-display pandadx9 Должно получиться: #load-display pandagl load-display pandadx9 #load-display pandadx8 #load-display pandagles #load-display tinydisplay

спасибо, все работает кроме fireflies и shadows - depth textures not supported + в др. примерах некоторые эффекты пропали
то есть дело в видеокарте?
 
serg-kkzДата: Воскресенье, 23.10.2011, 21:56 | Сообщение # 13
Генерал-лейтенант
Группа: Модераторы
Сообщений: 679
Награды: 3
Репутация: 16
Статус: Offline
Quote (deemaa)
примерах некоторые эффекты пропали то есть дело в видеокарте?

Это под DX рендерится. А панда его не полностью поддерживает. Здесь проблема в драйвере карты, почему то через OpengGL не хотит отоброжать шейдеры. Нужно поменять драйвер на видео карту и за одно обновить OpenGL х.з. может поможет.


ООП  -  
 
serg-kkzДата: Воскресенье, 23.10.2011, 22:08 | Сообщение # 14
Генерал-лейтенант
Группа: Модераторы
Сообщений: 679
Награды: 3
Репутация: 16
Статус: Offline
Еще как вариант можешь сменить ОС.

ООП  -  
 
ninthДата: Понедельник, 24.10.2011, 08:29 | Сообщение # 15
Admin
Группа: Администраторы
Сообщений: 1554
Награды: 5
Репутация: 46
Статус: Offline
Практически все ошибки сообщают о проблемах с обработкой шейдеров. Драйвера обновил? С оффсайта разработчика карточки, а не виндовые и не из виндовых сборок.
Для просмотра чего карточка из OGL умеет можешь скачать утилиту OpenGL Extension Viewer http://www.realtech-vr.com/glview/download.html
и глянуть Report.
 
Форум Panda3D - по русски » Panda3D » Общие вопросы » пару вопросов от новичка
Страница 1 из 3123»
Поиск: