[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
Страница 1 из 11
Форум Panda3D - по русски » Panda3D » Общие вопросы » Ошибка установки панды 1.7.0 на Мандриву 2010.2
Ошибка установки панды 1.7.0 на Мандриву 2010.2
backdoorДата: Суббота, 05.03.2011, 21:10 | Сообщение # 1
Рядовой
Группа: Пользователи
Сообщений: 6
Награды: 0
Репутация: 0
Статус: Offline
Здравствуйте! Ошибка установки, куда копать?

Code

[root@localhost panda3d-1.7.0]# makepanda/makepanda.py --everything
Generating library cache...
WARNING: Could not locate thirdparty package artoolkit, excluding from build
WARNING: Could not locate thirdparty package fcollada, excluding from build
WARNING: Could not locate thirdparty package ffmpeg, excluding from build
WARNING: Could not locate thirdparty package swscale, excluding from build
WARNING: Could not locate thirdparty package fftw, excluding from build
WARNING: Could not locate thirdparty package fmodex, excluding from build
WARNING: Could not locate thirdparty package nvidiacg, excluding from build
WARNING: Could not locate thirdparty package ode, excluding from build
WARNING: Could not locate thirdparty package opencv, excluding from build
WARNING: Could not locate thirdparty package squish, excluding from build
WARNING: Could not locate thirdparty package vrpn, excluding from build
WARNING: Could not locate thirdparty package tinyxml, excluding from build
Generating dependencies...
[  7%] Building C++ object built/tmp/express_composite1.o
In file included from panda/src/express/virtualFileMountMultifile.h:21,
                  from panda/src/express/config_express.cxx:25,
                  from panda/src/express/express_composite1.cxx:3:
panda/src/express/multifile.h:103: ошибка: ‘STACK’ has not been declared
In file included from panda/src/express/express_composite1.cxx:19:
panda/src/express/multifile.cxx:806: ошибка: ‘STACK’ has not been declared
panda/src/express/multifile.cxx: In member function ‘bool Multifile::add_signature(X509*, int*, EVP_PKEY*)’:
panda/src/express/multifile.cxx:812: ошибка: cannot convert ‘int*’ to ‘const _STACK*’ for argument ‘1’ to ‘int sk_num(const _STACK*)’
panda/src/express/multifile.cxx:814: ошибка: cannot convert ‘int*’ to ‘const _STACK*’ for argument ‘1’ to ‘void* sk_value(const _STACK*, int)’
panda/src/express/multifile.cxx: In member function ‘int Multifile::validate_signature_certificate(int) const’:
panda/src/express/multifile.cxx:1134: ошибка: нет декларации ‘STACK’ в этой области видимости
panda/src/express/multifile.cxx:1134: ошибка: нет декларации ‘stack’ в этой области видимости
Storing dependency cache.
Elapsed Time: 4 sec

Build terminated.
 
ninthДата: Суббота, 05.03.2011, 21:34 | Сообщение # 2
Admin
Группа: Администраторы
Сообщений: 1555
Награды: 5
Репутация: 46
Статус: Offline
На оффоруме по этому поводу говорят, что панда несовместима с последними версиями OpenSSL. Баг исправлен, но исходник надо тащить с cvs
 
backdoorДата: Понедельник, 14.03.2011, 01:16 | Сообщение # 3
Рядовой
Группа: Пользователи
Сообщений: 6
Награды: 0
Репутация: 0
Статус: Offline
установил 1.7.1, нормально стала. при попытке запустить примеры из папки samples, не видит модуль

Code
Traceback (most recent call last):
   File "./Tut-Distortion.py", line 3, in <module>
     import direct.directbase.DirectStart
ImportError: No module named direct.directbase.DirectStart


Сообщение отредактировал backdoor - Понедельник, 14.03.2011, 01:51
 
ninthДата: Понедельник, 14.03.2011, 08:17 | Сообщение # 4
Admin
Группа: Администраторы
Сообщений: 1555
Награды: 5
Репутация: 46
Статус: Offline
Здесь обсуждалось http://panda3d.org.ru/forum/3-137-1 смотри в конце.
 
backdoorДата: Понедельник, 14.03.2011, 13:45 | Сообщение # 5
Рядовой
Группа: Пользователи
Сообщений: 6
Награды: 0
Репутация: 0
Статус: Offline
прописал в PYTHONPATH путь с каталогом built, не видит теперь эти модули

Code
[bat@localhost Asteroids]$ python Tut-Asteroids.py
DirectStart: Starting the game.
Traceback (most recent call last):
   File "Tut-Asteroids.py", line 13, in <module>
     import direct.directbase.DirectStart
   File "/home/bat/panda3d-1.7.1/built/direct/directbase/DirectStart.py", line 3, in <module>
     from direct.showbase import ShowBase
   File "/home/bat/panda3d-1.7.1/built/direct/showbase/ShowBase.py", line 14, in <module>
     __builtin__.config = getConfigShowbase()
NameError: name 'getConfigShowbase' is not defined

Добавлено (14.03.2011, 13:45)
---------------------------------------------
подскажите что и куда прописывать, а то уже все перепробовал.

 
ninthДата: Понедельник, 14.03.2011, 15:59 | Сообщение # 6
Admin
Группа: Администраторы
Сообщений: 1555
Награды: 5
Репутация: 46
Статус: Offline
а makepanda/installpanda.py у тебя был выполнен?
 
backdoorДата: Понедельник, 14.03.2011, 22:37 | Сообщение # 7
Рядовой
Группа: Пользователи
Сообщений: 6
Награды: 0
Репутация: 0
Статус: Offline
Quote (ninth)
а makepanda/installpanda.py у тебя был выполнен?

ооооо

так, выполнил, баш написал. что устанавливает в /usr/local. потом, что установка завершено.
и какой путь писать в PYTHONPATH? прописал /usr/local.
запустил python /usr/local/share/panda3d/samples/Asteroids/Tut-Asteroids.py

вот вылетает

Code
DirectStart: Starting the game.
Traceback (most recent call last):
   File "/usr/local/share/panda3d/samples/Asteroids/Tut-Asteroids.py", line 13, in <module>
     import direct.directbase.DirectStart
   File "/usr/local/share/panda3d/direct/directbase/DirectStart.py", line 3, in <module>
     from direct.showbase import ShowBase
   File "/usr/local/share/panda3d/direct/showbase/ShowBase.py", line 10, in <module>
     from pandac.PandaModules import *
   File "/usr/local/share/panda3d/pandac/PandaModules.py", line 2, in <module>
     from libpandaexpressModules import *
   File "/usr/local/share/panda3d/pandac/libpandaexpressModules.py", line 1, in <module>
     from extension_native_helpers import *
   File "/usr/local/share/panda3d/pandac/extension_native_helpers.py", line 81, in <module>
     Dtool_PreloadDLL("libpandaexpress")
   File "/usr/local/share/panda3d/pandac/extension_native_helpers.py", line 79, in Dtool_PreloadDLL
     imp.load_dynamic(module, pathname)
ImportError: libp3dtool.so.1.7: cannot open shared object file: No such file or directory
 
ninthДата: Вторник, 15.03.2011, 08:13 | Сообщение # 8
Admin
Группа: Администраторы
Сообщений: 1555
Награды: 5
Репутация: 46
Статус: Offline
Ищи куда у тебя эта самая libp3dtool.so поставилась и добавляй путь в, если не ошибаюсь, LD_LIBRARY_PATH
Есть вариант что она у тебя вообще не скомпилилась - компилятор никаких ошибок не выдавал?
 
backdoorДата: Вторник, 15.03.2011, 12:16 | Сообщение # 9
Рядовой
Группа: Пользователи
Сообщений: 6
Награды: 0
Репутация: 0
Статус: Offline
прописал в LD_LIBRARY_PATH, usr/local/lib/panda3d, там этот модуль и находится.
вот теперь что:

Code
DirectStart: Starting the game.
Known pipe types:
    glxGraphicsPipe
(all display modules loaded.)
Ошибка сегментирования


Сообщение отредактировал backdoor - Вторник, 15.03.2011, 12:18
 
ninthДата: Вторник, 15.03.2011, 13:21 | Сообщение # 10
Admin
Группа: Администраторы
Сообщений: 1555
Награды: 5
Репутация: 46
Статус: Offline
Какая видеокарточка и какие дрова стоят?
Попробуй для проверки в Config.prc заменить load-display pandagl на load-display tinydisplay
 
backdoorДата: Вторник, 15.03.2011, 23:07 | Сообщение # 11
Рядовой
Группа: Пользователи
Сообщений: 6
Награды: 0
Репутация: 0
Статус: Offline
карта intel x3100. дрова из коробки мандривы стоит.
заменил, заработало.
вот только
Code
export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:"/usr/local/lib/panda3d"
приходится делать после каждой перезагрузки системы или даже запуска терминала

хм. еще пишет, что видео драйвер не поддерживает шейдеры. пичаль sad

Сообщение отредактировал backdoor - Вторник, 15.03.2011, 23:14
 
ninthДата: Среда, 16.03.2011, 08:32 | Сообщение # 12
Admin
Группа: Администраторы
Сообщений: 1555
Награды: 5
Репутация: 46
Статус: Offline
Попробуй добавь импорт в ~/.bashrc или ~/.profile (не знаю что в мандриве).
Интеловские карточки плохо дружат с OpenGL - с этим ничего не поделаешь (
 
Форум Panda3D - по русски » Panda3D » Общие вопросы » Ошибка установки панды 1.7.0 на Мандриву 2010.2
Страница 1 из 11
Поиск: