[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
Страница 1 из 11
Форум Panda3D - по русски » Panda3D » Общие вопросы » HELP! ошибки при компиляции панды 1.7 на opensuse 11.3 (HELP! ошибки при компиляции панды 1.7 на opensuse 11.3)
HELP! ошибки при компиляции панды 1.7 на opensuse 11.3
3BiPДата: Воскресенье, 13.02.2011, 16:20 | Сообщение # 1
Сержант
Группа: Пользователи
Сообщений: 37
Награды: 0
Репутация: 0
Статус: Offline
Скачал панду, компилирую так как нету установочного для opensuse 11.3.При компиляции возникает ошибка:

]Don't know how to compile: built/models/misc/camera.egg

Полностью компиляция:

Народ подскажите что делать?



 
ninthДата: Понедельник, 14.02.2011, 09:53 | Сообщение # 2
Admin
Группа: Администраторы
Сообщений: 1555
Награды: 5
Репутация: 46
Статус: Offline
Странная ошибка. Я с suse не работал но попробуй удовлетворить зависимости на которые варнинги висят, хотя бы основные. Дев версию питона, гтк, злиб, ссл и т.д.
 
3BiPДата: Понедельник, 14.02.2011, 14:43 | Сообщение # 3
Сержант
Группа: Пользователи
Сообщений: 37
Награды: 0
Репутация: 0
Статус: Offline
ninth, понимаете, большая часть из варнинга уже имеется. Питон 2.6 и т. д.
Может попытаться скомпилировать панду 1.6.2(предыдущую версию)? Я где-то на официальном форуме читал как они делали....
Многое я упущу если у меня будет не 1.7 ?



 
ninthДата: Среда, 16.02.2011, 01:41 | Сообщение # 4
Admin
Группа: Администраторы
Сообщений: 1555
Награды: 5
Репутация: 46
Статус: Offline
Quote (3BiP)
большая часть из варнинга уже имеется

Именно dev версии?

Quote (3BiP)
Многое я упущу если у меня будет не 1.7

Ну вообще 1.7 до выхода 1.7.1 считается экспериментальным и нестабильным. А так на вскидку из серьёзных изменений с версии 1.6.2 - плагин для браузера, возможно что-то из утилит для создания инсталлятора, автошейдер для теней.
 
3BiPДата: Воскресенье, 20.02.2011, 15:35 | Сообщение # 5
Сержант
Группа: Пользователи
Сообщений: 37
Награды: 0
Репутация: 0
Статус: Offline
Пробую скомпилировать 1.6.2 :

makepanda/makepanda.py --everything

-------------------------------------------------------------------
Makepanda Initial Status Report
Makepanda: Compiler: LINUX
Makepanda: Optimize: 3
Makepanda: Keep Pkg: PYTHON ZLIB PNG JPEG TIFF FMODEX OPENAL NVIDIACG OPENSSL FREETYPE FFTW ARTOOLKIT SQUISH ODE OPENCV FFMPEG FCOLLADA PANDATOOL
Makepanda: Omit Pkg: MAYA6 MAYA65 MAYA7 MAYA8 MAYA85 MAYA2008 MAYA2009 MAX6 MAX7 MAX8 MAX9 MAX2009 DX8 DX9 VRPN DIRECTCAM
Makepanda: Verbose vs. Quiet Level: 1
Makepanda: Don't generate API reference manual
Makepanda: Version ID: 1.6.2
Makepanda: DX8 only supported on windows yet
Makepanda: I have automatically added this command-line option: --no-dx8
Makepanda: DX9 only supported on windows yet
Makepanda: I have automatically added this command-line option: --no-dx9
Makepanda: DIRECTCAM only supported on windows yet
Makepanda: I have automatically added this command-line option: --no-directcam
Makepanda: I cannot locate SDK for MAYA6
Makepanda: I have automatically added this command-line option: --no-maya6
Makepanda: I cannot locate SDK for MAYA65
Makepanda: I have automatically added this command-line option: --no-maya65
Makepanda: I cannot locate SDK for MAYA7
Makepanda: I have automatically added this command-line option: --no-maya7
Makepanda: I cannot locate SDK for MAYA8
Makepanda: I have automatically added this command-line option: --no-maya8
Makepanda: I cannot locate SDK for MAYA85
Makepanda: I have automatically added this command-line option: --no-maya85
Makepanda: I cannot locate SDK for MAYA2008
Makepanda: I have automatically added this command-line option: --no-maya2008
Makepanda: I cannot locate SDK for MAYA2009
Makepanda: I have automatically added this command-line option: --no-maya2009
Makepanda: MAX6 only supported on windows yet
Makepanda: I have automatically added this command-line option: --no-max6
Makepanda: MAX7 only supported on windows yet
Makepanda: I have automatically added this command-line option: --no-max7
Makepanda: MAX8 only supported on windows yet
Makepanda: I have automatically added this command-line option: --no-max8
Makepanda: MAX9 only supported on windows yet
Makepanda: I have automatically added this command-line option: --no-max9
Makepanda: MAX2009 only supported on windows yet
Makepanda: I have automatically added this command-line option: --no-max2009
Makepanda: Caution: the built/lib directory is not in LD_LIBRARY_PATH
Makepanda: or /etc/ld.so.conf. You must add it before using panda.
Makepanda: I cannot locate SDK for VRPN in thirdparty directory.
Makepanda: I have automatically added this command-line option: --no-vrpn
-------------------------------------------------------------------

cp -R -f thirdparty/Pmw built/Pmw
Generating dependencies...
g++ -ftemplate-depth-30 -fPIC -c -o built/tmp/dtoolbase_composite1.o -I"/usr/include/python2.6" -I"built/tmp" -I"built/include" -Idtool/src/dtoolbase -O2 -DBUILDING_DTOOL dtool/src/dtoolbase/dtoolbase_composite1.cxx
g++ -ftemplate-depth-30 -fPIC -c -o built/tmp/dtoolbase_composite2.o -I"/usr/include/python2.6" -I"built/tmp" -I"built/include" -Idtool/src/dtoolbase -O2 -DBUILDING_DTOOL dtool/src/dtoolbase/dtoolbase_composite2.cxx
gcc -fPIC -c -o built/tmp/dtoolbase_lookup3.o -I"/usr/include/python2.6" -I"built/tmp" -I"built/include" -Idtool/src/dtoolbase -O2 -DBUILDING_DTOOL dtool/src/dtoolbase/lookup3.c
g++ -ftemplate-depth-30 -fPIC -c -o built/tmp/dtoolbase_indent.o -I"/usr/include/python2.6" -I"built/tmp" -I"built/include" -Idtool/src/dtoolbase -O2 -DBUILDING_DTOOL dtool/src/dtoolbase/indent.cxx
gcc -fPIC -c -o built/tmp/dtoolutil_gnu_getopt.o -I"/usr/include/python2.6" -I"built/tmp" -I"built/include" -Idtool/src/dtoolutil -O2 -DBUILDING_DTOOL dtool/src/dtoolutil/gnu_getopt.c
gcc -fPIC -c -o built/tmp/dtoolutil_gnu_getopt1.o -I"/usr/include/python2.6" -I"built/tmp" -I"built/include" -Idtool/src/dtoolutil -O2 -DBUILDING_DTOOL dtool/src/dtoolutil/gnu_getopt1.c
g++ -ftemplate-depth-30 -fPIC -c -o built/tmp/dtoolutil_composite.o -I"/usr/include/python2.6" -I"built/tmp" -I"built/include" -Idtool/src/dtoolutil -O2 -DBUILDING_DTOOL dtool/src/dtoolutil/dtoolutil_composite.cxx
g++ -ftemplate-depth-30 -fPIC -c -o built/tmp/dtool_dtool.o -I"/usr/include/python2.6" -I"built/tmp" -I"built/include" -Idtool/metalibs/dtool -O2 -DBUILDING_DTOOL dtool/metalibs/dtool/dtool.cxx
g++ -shared -o built/lib/libp3dtool.so -Lbuilt/lib -L/usr/X11R6/lib built/tmp/dtool_dtool.o built/tmp/dtoolutil_gnu_getopt.o built/tmp/dtoolutil_gnu_getopt1.o built/tmp/dtoolutil_composite.o built/tmp/dtoolbase_composite1.o built/tmp/dtoolbase_composite2.o built/tmp/dtoolbase_indent.o built/tmp/dtoolbase_lookup3.o -lpthread -ldl
bison -y -d -obuilt/tmp/cppBison.yxx.c -p cppyy dtool/src/cppparser/cppBison.yxx
g++ -ftemplate-depth-30 -fPIC -c -o built/tmp/cppParser_cppBison.o -I"/usr/include/python2.6" -I"built/tmp" -I"built/include" -Idtool/src/cppparser -O2 built/tmp/cppBison.yxx.cxx
CAUTION: file dependencies changed: ['built/include/cppBison.h']
g++ -ftemplate-depth-30 -fPIC -c -o built/tmp/cppParser_composite.o -I"/usr/include/python2.6" -I"built/tmp" -I"built/include" -Idtool/src/cppparser -O2 dtool/src/cppparser/cppParser_composite.cxx
ar cru built/tmp/libcppParser.a built/tmp/cppParser_composite.o built/tmp/cppParser_cppBison.o
g++ -ftemplate-depth-30 -fPIC -c -o built/tmp/prc_composite.o -I"/usr/include/python2.6" -I"built/tmp" -I"built/include" -Idtool/src/prc -O2 -DBUILDING_DTOOLCONFIG dtool/src/prc/prc_composite.cxx
In file included from dtool/src/prc/configPage.cxx:19:0,
from dtool/src/prc/prc_composite1.cxx:4,
from dtool/src/prc/prc_composite.cxx:1:
dtool/src/prc/prcKeyRegistry.h:27:25: fatal error: openssl/evp.h: No such file or directory
compilation terminated.
Storing dependency cache.
Elapsed Time: 22 sec

Хрень....
Пойду почитаю можт кто на офефоруме чтото писал....
Если есть идеи прошу сообщить

Добавлено (20.02.2011, 15:31)
---------------------------------------------
Воббщем пообщался с народом на оффоруме, смог поставить 1.7.0...всем спс

Добавлено (20.02.2011, 15:35)
---------------------------------------------
Терь проблема в этом:
Пытаюсь запутить привер и вот...

linux-0ff9:/opt/panda3d-1.7.0/samples/Chessboard # python Tut-Chessboard.py
DirectStart: Starting the game.
Traceback (most recent call last):
File "Tut-Chessboard.py", line 10, in <module>
import direct.directbase.DirectStart
File "/usr/share/panda3d/direct/directbase/DirectStart.py", line 3, in <module>
from direct.showbase import ShowBase
File "/usr/share/panda3d/direct/showbase/ShowBase.py", line 10, in <module>
from pandac.PandaModules import *
ImportError: No module named pandac.PandaModules



 
ninthДата: Воскресенье, 20.02.2011, 17:48 | Сообщение # 6
Admin
Группа: Администраторы
Сообщений: 1555
Награды: 5
Репутация: 46
Статус: Offline
А в чём проблема-то была? Интересно же.

Попробуй добавь в PYTHONPATH путь куда у тебя панда поставилась.

 
3BiPДата: Понедельник, 21.02.2011, 16:23 | Сообщение # 7
Сержант
Группа: Пользователи
Сообщений: 37
Награды: 0
Репутация: 0
Статус: Offline
ААА все сделанооо! примері не работали изиа того что мой питон не знал де панда, но панда поставил свой пптитон, и примері откріваются с помощью ppython, а не python.
А в установке была проблема изза того что я качал не самую последнюю версию для себя, и потом с помощью CVS я обновил его и скампилировал, попути сократил список варнинга до 5 )))...



 
Форум Panda3D - по русски » Panda3D » Общие вопросы » HELP! ошибки при компиляции панды 1.7 на opensuse 11.3 (HELP! ошибки при компиляции панды 1.7 на opensuse 11.3)
Страница 1 из 11
Поиск: